Blocked registration for dynamic tariffs

Incident Report for Kiwigrid GmbH

Postmortem

Customer Impact

The end-user may have experienced the inability to successfully complete the configuration of new contract creation as this process was disturbed, causing contracts to become stuck in an intermediate status.

Root Cause

The incident was caused by a recent configurational change that affected the service responsible for processing new contracts. This change inadvertently altered how the system managed internal data references and its access to the core contract management, leading to contract creation failures. The problem was not automatically contained due to a missing component in our messaging system, which has since been addressed and incomplete test cases.

Remediation

The issue was resolved by fixing the problematic part of the deployment. To prevent similar incidents, we have undertaken a fix within the messaging infrastructure and an improved test setup to cover these special cases.

Posted Dec 09, 2025 - 17:13 CET

Resolved

The ability to register dynamic tariffs is back up again and works as expected.
Posted Dec 01, 2025 - 13:50 CET

Identified

The issue is identified and the fix is currently under test.
Posted Nov 27, 2025 - 14:49 CET

Investigating

We are currently investigating this issue. At the moment it is not possible to newly register a dynamic tariff within TIH.hems and TTG.utility.
Customers with already registered dynamic tariffs are not affected.
Posted Nov 27, 2025 - 09:49 CET
This incident affected: SaaS (TIH.hems) and PaaS (TTG.utility).